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1.0 Introduction    
 

The Cruise Control Application Build is available for all Emtron ECUs.  This build allows 
unique application specific firmware to be installed into the ECU.    The strategy involves the 
ECU managing engine torque (Nm) by calculating the correct throttle area for the target 
vehicle speed.  The speed error is then corrected using a PID controller. It is important that 
the throttle body model is calibrated, and the engine model is correctly configured.  The air 
flow model using the throttle mass flow calculation (TMF) requires a pressure reference pre 
and post throttle.  In naturally aspirated applications the use of barometric pressure for the 
pre throttle channel will be enough to achieve reasonable results however it is 
recommended to install a pressure sensor pre throttle.  Turbocharged applications must run 
a pre throttle pressure sensor.  As shown in Table 1.0, any three boost pressure input 
channels may be used for the pre throttle pressure.   

 

 

DISCLAIMER 

(1) Cruise Control is designed to assist the driver and is not a substitute for safe and attentive driving practices. Please review 
the Cruise Control Application Build - Emtron, for important configuration instructions and cautions.  

 
(2) Any failure to follow the directions provided in the Cruise Control Application Build- Emtron is at the sole risk of the user. 

In no event shall Emtron Australia be liable for any physical or financial injury, loss or damage or consequential loss or 
damage of any kind arising out of or relating to the use or misuse of this product in contravention of the specified 
instructions and cautions presented in the Cruise Control Application Build- Emtron. 

 
(3) Not all vehicle configurations allow the use of Cruise Control due to hardware limitations. Please see your Cruise Control 

Application Build - Emtron, for further details and important safety information. Emtron Australia will not be liable for the 
improper use or improper setup of this function or product, and any physical or financial injury, loss or damage or 
consequential loss or damage, of any kind, arising from or relating to that improper use or improper setup. 

 
 

 



EMTRON CRUISE CONTROL APPLICATION BUILD WWW.EMTRON.WORLD 

  
 

  

© EMTRON AUSTRALIA PTY LTD AUGUST 2019 3 

 

Table 1.0 Input Channels for a Boost Pressure Sensor  

 

For further information on Throttle Mass Flow (TMF) refer to the Help Topic “Throttle Mass 
Flow Setup” located in the Emtune software package for a detailed explanation on how to 
configure and tune this system properly.  DO NOT attempt to use the Cruise Control 
function until TMF calibration is complete. 
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2.0 Build Setup  
 
The Cruise Control Application Build needs to be enabled by an authorised Emtron dealer 
before it may be installed into the ECU.  Each build is locked to an ECU serial number, then 
available for installation from the Emtron online server. 

 

2.1 Installation procedure:  
 

1. Internet access is required for the build installation allowing Emtune to access the 
Emtron online server. 

2. Connect Emtune to the ECU. 
3. Firmware Version 2.17.0 or later should be used. 
4. Select the File -> Build Management menu. A window will open and display all build 

options.  
5.  Select the Cruise Control option which should be listed as INSTALL. Press Ok. 

 

 
 

6. The installation process will take 5 -10 seconds.  A message box will confirm a 
successful installation. 

 



EMTRON CRUISE CONTROL APPLICATION BUILD WWW.EMTRON.WORLD 

  
 

  

© EMTRON AUSTRALIA PTY LTD AUGUST 2019 5 

 

7. To further verify the installation of the build was successful and to view the status of 
all available builds, open the Runtime menu (F3 Button) and select the “ECU 
Internal” tab. 
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2.2 Uninstall procedure:  
 
If the build has been previously installed it can be uninstalled at any time. 
 

1. Internet access is required for the build uninstall, allowing Emtune to access the 
Emtron online server. 

2. Connect Emtune to the ECU 
3. Select the File -> Build Management menu. A window will open and display all build 

options.  
4.  Select the Cruise Control option which should be listed as UNINSTALL. Press Ok. 

 

 

5. The uninstall  process will take 5 -10 seconds.  A message box will confirm a 
successful uninstall.  
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3.0 Configuration  
 
For the function to operate correctly the following minimum requirements MUST be 
adhered to: 

 

3.1 Input Switches  
 

Brake Switch  
Clutch Switch * 
Cruise Enable Switch  
Cruise SET/COAST Switch  
Cruise RESUME/ACCEL Switch 
Cruise CANCEL Switch  

 
*Manual Transmission with mechanical clutch  

 

 

Table 3.0 Input Setup form input channels  
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3.2 Sensors  
 

Speed Sensor  
Boost Pressure Sensor (Pre plate pressure sensor) 
Inlet Manifold Pressure Sensor (After plate pressure sensor) 
Pedal Position Sensor Main   
Pedal Position Sensor Sub 
Servo Position Sensor Main 
Servo Position Sensor Sub 

 

3.3 Hardware  
 
Electronic Throttle Body (DBW) 
Throttle Pedal with two (2) position sensors   
 

3.4 Function Lockouts  
 
The ECU is constantly monitoring the required channels and will lockout cruise control if one 
(1) of these are either not configured, in fault or are not selected.  See below: 

 
Critical Lockouts: 

 
1. "X-TMF1 Sensor Before Fault": Sensor in fault or is not selected for DBW 1 

2. "X-TMF1 Sensor After Plate Fault":  Sensor in fault or is not selected  DBW 1 
3. "X-TMF2 Sensor Before Fault": Sensor in fault or is not selected for DBW 2 
4. "X-TMF2 Sensor After Plate Fault":  Sensor in fault or is not selected  DBW 2 
5. "X-TMF Disabled" : Throttle Mass Flow function is off so Cruise Control is disabled  
6. "X-  Cruise Enable Sw Config". The Cruise Control Enable (Off/On) switch is not 

configured  
7. " X- Cruise SET Sw Config".  Cruise Control Set switch is not configured  
8. " X- Cruise RESUME Sw Config" Cruise Control Resume switch is not configured  
9. "X- Cruise CANCEL Sw Config". Cruise Control Cancel switch is not configured  
10. " X- Cruise No Sw Config".  There are no Cruise Control switches configured 
11. “X-Speed Source Config”. There is no Cruise Speed channel configured 
12. “X-Brake Input Config. There is no Brake switch configured  
13. “X-Firmware Lockout”. Application build is disabled. 
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Non-Critical  Lockouts 

1. OFF-Cruise Enable Sw 
2. OFF-Cruise Cancel Sw 
3. OFF-Engine Speed Zero 
4. OFF-Ref Speed Zero 
5. OFF-Limiting Active  
6. OFF-Brake Switch 
7. OFF-Neutral 
8. OFF-Clutch Switch 

The Cruise Control Status runtime will update to indicate which condition is locking out the 
function. An example is shown in Figure 3.0. 
 

 
Figure 3.0. Runtime menu, Cruise Control Runtimes 

 

3.5 Function Enable 
 

Once the Cruise Control Build is enabled the function needs to be enabled.   
Config->Functions->Function Output Setup->Vehicles Functions 2->Cruise Control .  See 
Table 3.1. 
 

 
Table 3.1 Function Output Setup form 
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4.0 Tuning System  
 

Calibration of the Cruise Control system is done in the Emtune Tuning View tab. 

Tuning->Vehicle Function->Cruise Control->Cruise Setup 

 

 

Table 4.0 Tuning View Cruise Control Menu  

 

4.1 Cruise Setup  
 

 
 

Cruise Max Target Speed  

This is the maximum target speed that can be set.  The ECU clamps to this value.    
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Cruise Resume Speed Incr Ramp Time  
 
This is the time the ECU will gradually increase the speed target back to the previously “Set” speed 
after a lockout has been invoked.  This is to achieve a smooth acceleration rate back to the target 
speed. 
 

Cruise Resume Speed Decr Ramp Time  
 
This is the time the ECU will gradually decrease the speed target back to the previously “Set” speed 
after a lockout state has been cleared.  This is to achieve a smooth transition back to the target 
speed. 
 

4.2 Cruise Closed Loop Setup 
 
The system relies on a combination of feedforward TMF torque based latching coupled with a PID 
system to control the speed.   
 

 
 
Cruise Control Speed Channel 

Any speed channel in the ECU may be used as the input channel. This is used by the speed target. 
 

Cruise Proportional Gain 

This is the gain due to the instantaneous error in speed. Typical value 1.00 
 

Cruise Integral Gain 

This is the gain due to the error with respect to time. Typical value 0.010 
 

Cruise Derivative Gain 

This is the gain due the rate of change of the error. Typical value 12.00 
 

Cruise Deadband +/- 

This is the speed range which will hold the output. Typical value 0.2km/h 
 

 

 



EMTRON CRUISE CONTROL APPLICATION BUILD WWW.EMTRON.WORLD 

  
 

  

© EMTRON AUSTRALIA PTY LTD AUGUST 2019 12 

 

Cruise Maximum Torque Clamp  

The maximum clamp the system can use to attain the target speed.  Set to allow the system enough 
torque to always achieve the target.  Typical value 200-300 Nm 
 

Cruise Minimum Torque Clamp  

 
The minimum clamp the system can use to attain the target speed. Usually this will be set to ensure 
maximum deceleration.   Typical value -100 Nm 
 

The system employs an error counter which is triggered when the Cruise Minimum Torque Clamp 
and the Maximum Torque Clamp have been hit.   The larger the target error when the torque clamps 
are latched the faster the error counter will increment.  The system will shut down once the counter 
reaches the pre-determined value set.  This setting is not adjustable by the user. 
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4.3 Runtimes 
 
The runtimes relating to the function may be accessed for quick viewing through the ECU Runtime 
Menu by pressing the F3 hotkey: 
   
Runtime Data->Vehicle Functions->Cruise Control 
 

 
Table 4.1 ECU runtime values for Cruise Control  
 
 

Cruise Control Status: The current system status.   

• Disabled: System is OFF 

• ON: System is currently active  

• ... Waiting SET/RESUME Sw: System is armed however in a lockout state awaiting user input 
to re- engage 

• Starting-SET Pressed: Set has been pressed and the system will become active.  The current 
speed will be loaded as the “Speed Target” 

• Restarting-RESUME Pressed: The system will resume and the last loaded Speed Target will 
be re engaged. 

• ON – Paused Pedal: The system is active but the driver is inputting a higher throttle area 
demand than is being requested.  Normal operation will resume after the driver input is 
removed.  As this state is controlled by the pedal area demanded, it is important that the 
“Pedal to Throttle Area Translation Table” has a 0.0 setting in the “Pedal Position Demand” 
0% axis.     

 

Cruise – Torque Target Base (TMF) 
 
When the system becomes active the TMF calculated torque value is loaded and used as the base 
torque reference.  This is then converted into a throttle area demand.   
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Cruise – Torque Target Final (TMF) 

 
The PID system adjusts the Torque output using the Torque Target Base as a feed forward.  
It will continue to adjust this value which is then converted into a throttle area demand in 
order to achieve the target speed. 

 
Cruise – Speed Target 
 

This is speed target loaded that the PID will attempt to achieve. 

 
Cruise – Speed Input 
 

This is the actual reported speed the system is referencing.  The user selected channel speed 
is used and reported here. 

 
Cruise RESUME Sw  
 

Switch state for the RESUME switch.  This should be monitored to confirm the correct 
button assignment. 

 
Cruise SET Sw 
 

Switch state for the SET switch.  This should be monitored to confirm the correct button 
assignment. 
 
Cruise CANCEL Sw 
 
Switch state for the CANCEL switch.  This should be monitored to confirm the correct button 
assignment. 
 
Cruise ON/OFF Sw 
 
Switch state for the ON/OFF switch.  This is the main enable switch for the cruise control 
system.  This should be monitored to confirm the correct button assignment.  
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Appendix A - Bit CAN Message Information 
 

Bit CAN Message Information for “Cruise Control Status” runtime 

 0 Disabled  
 1 ON  
 2 ... Waiting SET/RESUME Sw  
 3 Starting-SET Pressed  
 4 Restarting-RESUME Pressed  
 5 ON - Paused Pedal  
 6 ----- 
 7 ----- 
 8 ----- 
 9 ----- 
 10 ----- 
 11 ----- 
 12 ----- 
 13 ----- 
 14 ----- 
 15 ----- 
 16 ----- 
 17 ----- 
 18 ----- 
 19 -----  
 20 OFF-Cruise Enable Sw  
 21 OFF-Cruise Cancel Sw  
 22 OFF-Engine Speed Zero   
 23 OFF-Ref Speed Zero  
 24 OFF-Limiting Active  
 25 OFF-Brake Switch  
 26 OFF-Neutral  
 27 OFF-Clutch Switch  
 28 -----  
 29 X- TMF Disabled  
 30 X-TMF1 Sensor Before Fault  
 31 X-TMF1 Sensor After Fault  
 32 X-TMF2 Sensor Before Fault  
 33 X-TMF2 Sensor After Fault  
 34 X-Cruise Enable Sw Config  
 35 X-Cruise SET Sw Config  
 36 X-Cruise RESUME Sw Config  
 37 X-Cruise CANCEL Sw Config  
 38 X-Speed Source Config  
 39 X-Brake Input Config  
 40 X-Firmware Lockout 


